Protocolo RIP - Lab com passo-a-passo em roteadores Cisco


O RIP ou Routing Information Protocol é um protocolo aberto, definido na RFC 1058, e classificado como vetor de distância.

As diferenças básicas entre o RIP versão 1 e versão 2 é que o primeiro é classfull, ou seja, suporta apenas classes cheias (A, B ou C) ou subrede com a mesma máscara e troca atualizações de roteamento via broadcast.

Já a versão 2 suporta CIDR (classless) e VLSM (divisão de subredes com várias máscaras de subrede), além disso, troca informações através de multicast no endereço 224.0.0.9.

Ambas as versões trocam informações utilizando UDP na porta 520.

Para IPv6 (versão 6 do protocolo IP) o RIP passa a chamar RIPng (Next Generation) e funciona basicamente da mesma maneira que o RIP versão 2 para IPv4, porém enviando updates no endereço IPv6 de multicast FF02::9.

Para configurar o RIP versão 1 basta ativar o protocolo com o comando “router rip”, depois em modo de configuração do roteador definir as redes que serão anunciadas com o comando “network”.

No comando network você deve utilizar apenas as redes classfull e não subredes, por exemplo, se no roteador você tem as redes 10.0.0.0/24 e 10.0.1.0/24 você deve anunciar "network 10.0.0.0", ou seja, apenas a classe A cheia, sem subredes.

Por padrão, com a configuração citada acima você terá o RIP versão 1 ativado, para ativar a versão 2 basta adicionar o comando “version 2″.

Vamos ver um exemplo simples de configuração do RIP para o R2 da topologia abaixo.

Configuração do RIP v1 no roteador R2


R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.0.0


Configuração do RIP v2 no roteador R2


R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.0.0


O comando no "auto-summary" desabilita a sumarização automática em redes classfull, apesar de nesse caso não ser necessário por todas as redes serem classe C o comando é recomendado pela Cisco.

Se estivéssemos utilizando subrede o roteador sem esse comando enviaria para o vizinho apenas um anúncio com a rede classe A, B ou C utilizada como base para as subredes.

Para configurar rotas em roteadores, temos duas opções: criar rotas estáticas e/ou utilizar protocolos de roteamento.

Protocolo de roteamento, na verdade, é um algoritmo que serve para preencher a tabela de roteamento de um roteador, com isso o roteador consegue dinamicamente apreender sobre as novas redes e quando as redes são desativadas por algum motivo.

Temos vários protocolos de roteamento utilizados na internet. Podemos classificar os protocolos de roteamento como:

  • IGP – Interior Gateway Protocol, Exemplos: RIP, OSPF, EIGRP (proprietário Cisco) e etc.
  • EGP – Exterior Gateway Protocol, Exemplos: BGP e IS-IS
  • RIP – Routing Information Protocol


O RIP é um protocolo de roteamento classificado como Vetor de Distância. Atualmente ele possui 2 versões que trabalham com o IPv4:

RIP Versão 1 – A versão 1 do RIP é limitada em comparação com as redes atuais, na sua época de lançamento supria todas as necessidades. Abaixo segue algumas características do RIPv1.

Classfull, Limite de 15 saltos, Broadcast.


RIP Versão 2 – A versão 2 do RIP tem muitas melhorias que suprem as tecnologias e técnicas das redes atuais.

Classless, Limite 15 saltos, Multicast, Autenticação.


Prática


Abaixo está o cenário.


 



Configurar o Router A



Configuração da Interface Serial 0/0/0 → Conectada ao router B

Router_A(config)#inter s0/0/0
Router_A(config-if)#clock rate 64000
Router_A(config-if)#ip address 200.200.10.1 255.255.255.252
Router_A(config-if)#no shutdown



Configuração da Interface FastEthernet 0/0 → Conectada ao host A
Router_A(config)#inter fastEthernet 0/0
Router_A(config-if)#ip address 192.168.0.1 255.255.255.0
Router_A(config-if)#no shutdown




Configuração do RIPv2 no Router A

Router_A(config)#router rip
Router_A(config-router)#network 200.200.10.0
Router_A(config-router)#network 192.168.0.0
Router_A(config-router)#version 2





    Agora vamos verificar o status das interfaces no Router A.

Router_A#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.0.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/0/0 200.200.10.1 YES manual down down
Vlan1 unassigned YES unset administratively down down



Veja que a Serial0/0/0 está Down, mesmo executando o comando no shutdown nessa interface ela não fica UP até a outra ponta (Router B) está configurada e com o comando no shutdown.






Configurar o Router B




Configuração da Interface Serial0/0/1 (interface que está ligada ao Router A)


Router_B(config)#inter s0/0/1
Router_B(config-if)#ip address 200.200.10.2 255.255.255.252
Router_B(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up


Vejam que assim que damos o comando no shutdown nessa interface, é mostrada a mensagem que a Interface está UP.


Voltemos ao Router A, vamos verificar a interface se ela ficou UP agora.


Router_A#show ip inter brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.0.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/0/0 200.200.10.1 YES manual up up
Vlan1 unassigned YES unset administratively down down



Pronto! A interface S0/0/0 está UP, e o Router A já pode se comunicar com o Router B.


Router_A#ping 200.200.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/28/32 ms


 



Nota: Essa comunicação entre o Router A e Router B não está sendo utilizada pelo RIP, pois a Rede de ambos está diretamente conectada. Vejamos a tabela de Roteamento do Router B.



Router_B#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
200.200.10.0/30 is subnetted, 1 subnets
C 200.200.10.0 is directly connected, Serial0/0/1

 



Configuração da Serial 0/0/1 do Router B → Conectada ao Router C


Router_B(config)#inter s0/0/1
Router_B(config-if)#ip address 200.200.10.5 255.255.255.252
Router_B(config-if)#clock rate 64000
Router_B(config-if)#no shutdown




Configuração do RIPv2 no Router B


Router_B(config)#router rip
Router_B(config-router)#version 2
Router_B(config-router)#network 200.200.10.4
Router_B(config-router)#network 200.200.10.0





Configurar o Router C



Configuração da Serial 0/0/0 do Router C → Conectado ao Router B


Router_C(config)#inter s0/0/0
Router_C(config-if)#ip address 200.200.10.6 255.255.255.252
Router_C(config-if)#no shutdown




Configuração da FastEthernet 0/0 do Router C → Conectada ao Host B


Router_C(config)#inter fastEthernet 0/0
Router_C(config-if)#ip address 192.168.1.1 255.255.255.0
Router_C(config-if)#no shutdown



Configuração do RIPv2 no Router C


Router_C(config)#router rip
Router_C(config-router)#version 2
Router_C(config-router)#network 192.168.1.0
Router_C(config-router)#network 200.200.10.4



 




Verificando a tabela de roteamento de cada Router.



Tabela de Roteamento – Router A


Router_A#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set

C 192.168.0.0/24 is directly connected, FastEthernet0/0
R 192.168.1.0/24 [120/2] via 200.200.10.2, 00:00:26, Serial0/0/0
200.200.10.0/30 is subnetted, 2 subnets
C 200.200.10.0 is directly connected, Serial0/0/0
R 200.200.10.4 [120/1] via 200.200.10.2, 00:00:26, Serial0/0/0




Tabela de Roteamento – Router B
Router_B#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
R 192.168.0.0/24 [120/1] via 200.200.10.1, 00:00:01, Serial0/0/1
R 192.168.1.0/24 [120/1] via 200.200.10.6, 00:00:20, Serial0/0/0
200.200.10.0/30 is subnetted, 2 subnets
C 200.200.10.0 is directly connected, Serial0/0/1
C 200.200.10.4 is directly connected, Serial0/0/0





Tabela de Roteamento – Router C


Router_C#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set

R 192.168.0.0/24 [120/2] via 200.200.10.5, 00:00:15, Serial0/0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
200.200.10.0/30 is subnetted, 2 subnets
R 200.200.10.0 [120/1] via 200.200.10.5, 00:00:15, Serial0/0/0
C 200.200.10.4 is directly connected, Serial0/0/0


Pronto! Todos os roteadores estão com a sua tabela de roteamento preenchida corretamente e com isso o Host A pode se comunicar com o Host B e vice-versa.



Testando a conectividade dos hosts




Host A para Host B

PC>ping 192.168.1.2
Pinging 192.168.1.2 with 32 bytes of data:
Request timed out.
Reply from 192.168.1.2: bytes=32 time=32ms TTL=125
Reply from 192.168.1.2: bytes=32 time=24ms TTL=125
Reply from 192.168.1.2: bytes=32 time=22ms TTL=125
Ping statistics for 192.168.1.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 22ms, Maximum = 32ms, Average = 26ms




Host B para Host A

PC>ping 192.168.0.2
Pinging 192.168.0.2 with 32 bytes of data:
Reply from 192.168.0.2: bytes=32 time=20ms TTL=125
Reply from 192.168.0.2: bytes=32 time=24ms TTL=125
Reply from 192.168.0.2: bytes=32 time=22ms TTL=125
Reply from 192.168.0.2: bytes=32 time=14ms TTL=125
Ping statistics for 192.168.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 14ms, Maximum = 24ms, Average = 20ms





fonte: https://edvanbarros.wordpress.com/

Mais vistos no mês:

As melhores distribuições Linux para 2017

Teste de Performance de Rede com Iperf

TuxMath - Tux, do Comando da Matemática. Ensino e diversão a crianças.

Aula #14 - Os sistemas de arquivos ext2/ext3/ext4

OPNsense - Firewall Open Source

Modelo Firewall Completo em Iptables para pequena rede/office

DHCP - Guia Completo

SSD no linux

Administração de sistema e Deploys: Ansible, Chef, Fabric, Puppet ou Salt?